Applets

Select an applet from the list to the left.

Back in the day, I created a number of applets, with a varying degree of originality, entertainment value, and completedness. Unfortunately, two of the more interesting ones were multiplayer games (Sudoku and a snake-game I called WormWars) and I no longer have the time and passion to run the server-side components.

All applets should work with Java 1.4 or later, which can be downloaded from www.java.com.

Many of the older applets will work with Java 1.1 or later, but if an applet fails to load, your version of Java is probably not recent enough. Click here to see what version of java you have installed.